Project

General

Profile

Bug #83

Mulgara fails to start after abrupt termination

Added by ronald - over 12 years ago. Updated almost 12 years ago.

Status:
Feedback
Priority:
High
Assignee:
Category:
Mulgara
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

I killed mulgara abruptly, and subsequently it failed to start.
According to Andrae's initial analysis, the problem is that mulgara
assumes during recovery that certain deleted structures are internally
valid when in this case they aren't.

Attached is the db from after the crash. The failure to recover seems to
be reproducable only on 32-bit jvm's, and even then not consistently
(due to the timing between certain operations).

#1

Updated by Paula Gearon almost 12 years ago

  • Status changed from New to Closed
  • Resolution set to fixed
#2

Updated by Paula Gearon almost 12 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

Also available in: Atom PDF