Project

General

Profile

Bug #45

doclet error during javadoc build

Added by ronald - almost 16 years ago. Updated over 15 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Mulgara
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed

Description

While building the javadocs, the following error occurs a couple times:
<br/>

<br/>
&nbsp;&nbsp;[javadoc] Building tree for all the packages and classes...
<br/>
&nbsp;&nbsp;[javadoc] java.lang.IllegalArgumentException: Illegal group reference
<br/>
&nbsp;&nbsp;[javadoc]     at java.util.regex.Matcher.appendReplacement(Matcher.java:713)
<br/>
&nbsp;&nbsp;[javadoc]     at org.mulgara.doclet.RCSTaglet.replaceRcsKeywords(RCSTaglet.java:198)
<br/>
&nbsp;&nbsp;[javadoc]     at org.mulgara.doclet.RCSTaglet.toString(RCSTaglet.java:128)
<br/>

<br/>
The problem is that any $ needs to be escaped in the replacement string.
<br/>

<br/>
A simple patch for this is attached.
#1

Updated by ronald - over 15 years ago

Patch applied in rev <a href="http://mulgara.org/trac/changeset/195">#195</a>.

Also available in: Atom PDF