Project

General

Profile

Bug #209

Error restoring database

Added by Dragisa Krsmanovic - over 14 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Mulgara
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
invalid

Description

restore <local:///topazproject> from <file:/backup/serverbackup.gz>; fails after > 1h of work.

Affected version is 2.0.14
Platform is CentOS 32bit (an EC2 instance)

Mulgara run command:

java -server -Xmx400m -XX:MaxPermSize=256m -Djava.rmi.dgc.leaseValue=30000 -jar /usr/local/topaz/topaz-mulgara/mulgara-service-0.9.6-SNAPSHOT.jar -l file:///usr/local/topaz/topaz-mulgara/log4j.xml -s topazproject -a /var/lib/topaz/data/mulgara -r 8111 -t 8111 --nohttp

Stack trace:

Rolling back transaction...
2009-12-03 14:56:43,062 WARN  [[RemoteXAResourceWrapperXAResource]]> RMI Error in XAResource
java.rmi.NoSuchObjectException: no such object in table
    at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:255)
    at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:233)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:142)
    at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:178)
    at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:132)
    at $Proxy0.end(Unknown Source)
    at org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource.end(RemoteXAResourceWrapperXAResource.java:78)
    at bitronix.tm.internal.XAResourceHolderState.end(XAResourceHolderState.java:131)
    at bitronix.tm.internal.XAResourceManager.delist(XAResourceManager.java:112)
    at bitronix.tm.BitronixTransaction.delistResource(BitronixTransaction.java:103)
    at bitronix.tm.BitronixTransaction.delistUnclosedResources(BitronixTransaction.java:309)
    at bitronix.tm.BitronixTransaction.rollback(BitronixTransaction.java:202)
    at org.topazproject.otm.impl.TransactionImpl.rollback(TransactionImpl.java:98)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
    at org.codehaus.groovy.runtime.InvokerHelper.invokePojoMethod(InvokerHelper.java:738)
    at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:726)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethod0(ScriptBytecodeAdapter.java:198)
    at [[RunTql]].doQuery(RunTql.groovy:302)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].execute(RunTql.groovy:271)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].processLine(RunTql.groovy:368)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].run(RunTql.groovy:399)
    at groovy.lang.GroovyShell.runMainOrTestOrRunnable(GroovyShell.java:254)
    at groovy.lang.GroovyShell.run(GroovyShell.java:218)
    at groovy.lang.GroovyShell.run(GroovyShell.java:147)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
    at org.codehaus.groovy.runtime.InvokerHelper.invokePogoMethod(InvokerHelper.java:750)
    at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:730)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
    at [[RunGroovy]].run(RunGroovy.groovy:34)
    at groovy.lang.GroovyShell.runMainOrTestOrRunnable(GroovyShell.java:254)
    at groovy.lang.GroovyShell.run(GroovyShell.java:218)
    at groovy.lang.GroovyShell.run(GroovyShell.java:147)
    at groovy.ui.GroovyMain.processOnce(GroovyMain.java:493)
    at groovy.ui.GroovyMain.run(GroovyMain.java:308)
    at groovy.ui.GroovyMain.process(GroovyMain.java:294)
    at groovy.ui.GroovyMain.processArgs(GroovyMain.java:111)
    at groovy.ui.GroovyMain.main(GroovyMain.java:92)
2009-12-03 14:56:43,170 WARN  [[BitronixTransaction]]> error delisting resource: an XAResourceHolderState with uniqueName=org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource758681182 XAResource=org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource@2d388e5e (started) with XID a Bitronix XID [746F70617A0000012555B7941200000002 : 746F70617A0000012555B7941700000003]
bitronix.tm.internal.BitronixSystemException: cannot delist an XAResourceHolderState with uniqueName=org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource758681182 XAResource=org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource@2d388e5e (started) with XID a Bitronix XID [746F70617A0000012555B7941200000002 : 746F70617A0000012555B7941700000003], error=XAER_RMFAIL
    at bitronix.tm.BitronixTransaction.delistResource(BitronixTransaction.java:116)
    at bitronix.tm.BitronixTransaction.delistUnclosedResources(BitronixTransaction.java:309)
    at bitronix.tm.BitronixTransaction.rollback(BitronixTransaction.java:202)
    at org.topazproject.otm.impl.TransactionImpl.rollback(TransactionImpl.java:98)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
    at org.codehaus.groovy.runtime.InvokerHelper.invokePojoMethod(InvokerHelper.java:738)
    at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:726)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethod0(ScriptBytecodeAdapter.java:198)
    at [[RunTql]].doQuery(RunTql.groovy:302)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].execute(RunTql.groovy:271)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].processLine(RunTql.groovy:368)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].run(RunTql.groovy:399)
    at groovy.lang.GroovyShell.runMainOrTestOrRunnable(GroovyShell.java:254)
    at groovy.lang.GroovyShell.run(GroovyShell.java:218)
    at groovy.lang.GroovyShell.run(GroovyShell.java:147)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
    at org.codehaus.groovy.runtime.InvokerHelper.invokePogoMethod(InvokerHelper.java:750)
    at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:730)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
    at [[RunGroovy]].run(RunGroovy.groovy:34)
    at groovy.lang.GroovyShell.runMainOrTestOrRunnable(GroovyShell.java:254)
    at groovy.lang.GroovyShell.run(GroovyShell.java:218)
    at groovy.lang.GroovyShell.run(GroovyShell.java:147)
    at groovy.ui.GroovyMain.processOnce(GroovyMain.java:493)
    at groovy.ui.GroovyMain.run(GroovyMain.java:308)
    at groovy.ui.GroovyMain.process(GroovyMain.java:294)
    at groovy.ui.GroovyMain.processArgs(GroovyMain.java:111)
    at groovy.ui.GroovyMain.main(GroovyMain.java:92)
Caused by: javax.transaction.xa.XAException
    at org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource.end(RemoteXAResourceWrapperXAResource.java:81)
    at bitronix.tm.internal.XAResourceHolderState.end(XAResourceHolderState.java:131)
    at bitronix.tm.internal.XAResourceManager.delist(XAResourceManager.java:112)
    at bitronix.tm.BitronixTransaction.delistResource(BitronixTransaction.java:103)
    ... 66 more
2009-12-03 14:56:43,175 WARN  [[RemoteXAResourceWrapperXAResource]]> RMI Error in XAResource
java.rmi.NoSuchObjectException: no such object in table
    at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:255)
    at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:233)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:142)
    at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:178)
    at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:132)
    at $Proxy0.rollback(Unknown Source)
    at org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource.rollback(RemoteXAResourceWrapperXAResource.java:151)
    at bitronix.tm.twopc.Rollbacker$RollbackJob.rollbackResource(Rollbacker.java:133)
    at bitronix.tm.twopc.Rollbacker$RollbackJob.run(Rollbacker.java:122)
    at bitronix.tm.twopc.executor.SyncExecutor.submit(SyncExecutor.java:12)
    at bitronix.tm.twopc.AbstractPhaseEngine.runJobsForPosition(AbstractPhaseEngine.java:108)
    at bitronix.tm.twopc.AbstractPhaseEngine.executePhase(AbstractPhaseEngine.java:70)
    at bitronix.tm.twopc.Rollbacker.rollback(Rollbacker.java:51)
    at bitronix.tm.BitronixTransaction.rollback(BitronixTransaction.java:211)
    at org.topazproject.otm.impl.TransactionImpl.rollback(TransactionImpl.java:98)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
    at org.codehaus.groovy.runtime.InvokerHelper.invokePojoMethod(InvokerHelper.java:738)
    at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:726)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethod0(ScriptBytecodeAdapter.java:198)
    at [[RunTql]].doQuery(RunTql.groovy:302)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].execute(RunTql.groovy:271)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].processLine(RunTql.groovy:368)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].run(RunTql.groovy:399)
    at groovy.lang.GroovyShell.runMainOrTestOrRunnable(GroovyShell.java:254)
    at groovy.lang.GroovyShell.run(GroovyShell.java:218)
    at groovy.lang.GroovyShell.run(GroovyShell.java:147)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
    at org.codehaus.groovy.runtime.InvokerHelper.invokePogoMethod(InvokerHelper.java:750)
    at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:730)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
    at [[RunGroovy]].run(RunGroovy.groovy:34)
    at groovy.lang.GroovyShell.runMainOrTestOrRunnable(GroovyShell.java:254)
    at groovy.lang.GroovyShell.run(GroovyShell.java:218)
    at groovy.lang.GroovyShell.run(GroovyShell.java:147)
    at groovy.ui.GroovyMain.processOnce(GroovyMain.java:493)
    at groovy.ui.GroovyMain.run(GroovyMain.java:308)
    at groovy.ui.GroovyMain.process(GroovyMain.java:294)
    at groovy.ui.GroovyMain.processArgs(GroovyMain.java:111)
    at groovy.ui.GroovyMain.main(GroovyMain.java:92)
2009-12-03 14:56:43,618 ERROR [[AbstractPhaseEngine]]> resource org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource758681182 failed on a Bitronix XID [746F70617A0000012555B7941200000002 : 746F70617A0000012555B7941700000003]
bitronix.tm.internal.BitronixXAException: resource reported XAER_RMFAIL when asked to rollback transaction branch
    at bitronix.tm.twopc.Rollbacker$RollbackJob.handleXAException(Rollbacker.java:153)
    at bitronix.tm.twopc.Rollbacker$RollbackJob.rollbackResource(Rollbacker.java:136)
    at bitronix.tm.twopc.Rollbacker$RollbackJob.run(Rollbacker.java:122)
    at bitronix.tm.twopc.executor.SyncExecutor.submit(SyncExecutor.java:12)
    at bitronix.tm.twopc.AbstractPhaseEngine.runJobsForPosition(AbstractPhaseEngine.java:108)
    at bitronix.tm.twopc.AbstractPhaseEngine.executePhase(AbstractPhaseEngine.java:70)
    at bitronix.tm.twopc.Rollbacker.rollback(Rollbacker.java:51)
    at bitronix.tm.BitronixTransaction.rollback(BitronixTransaction.java:211)
    at org.topazproject.otm.impl.TransactionImpl.rollback(TransactionImpl.java:98)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
    at org.codehaus.groovy.runtime.InvokerHelper.invokePojoMethod(InvokerHelper.java:738)
    at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:726)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethod0(ScriptBytecodeAdapter.java:198)
    at [[RunTql]].doQuery(RunTql.groovy:302)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].execute(RunTql.groovy:271)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].processLine(RunTql.groovy:368)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
    at [[RunTql]].run(RunTql.groovy:399)
    at groovy.lang.GroovyShell.runMainOrTestOrRunnable(GroovyShell.java:254)
    at groovy.lang.GroovyShell.run(GroovyShell.java:218)
    at groovy.lang.GroovyShell.run(GroovyShell.java:147)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
    at org.codehaus.groovy.runtime.InvokerHelper.invokePogoMethod(InvokerHelper.java:750)
    at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:730)
    at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
    at [[RunGroovy]].run(RunGroovy.groovy:34)
    at groovy.lang.GroovyShell.runMainOrTestOrRunnable(GroovyShell.java:254)
    at groovy.lang.GroovyShell.run(GroovyShell.java:218)
    at groovy.lang.GroovyShell.run(GroovyShell.java:147)
    at groovy.ui.GroovyMain.processOnce(GroovyMain.java:493)
    at groovy.ui.GroovyMain.run(GroovyMain.java:308)
    at groovy.ui.GroovyMain.process(GroovyMain.java:294)
    at groovy.ui.GroovyMain.processArgs(GroovyMain.java:111)
    at groovy.ui.GroovyMain.main(GroovyMain.java:92)
Caused by: javax.transaction.xa.XAException
    at org.mulgara.server.rmi.RemoteXAResourceWrapperXAResource.rollback(RemoteXAResourceWrapperXAResource.java:154)
    at bitronix.tm.twopc.Rollbacker$RollbackJob.rollbackResource(Rollbacker.java:133)
    ... 70 more
Error running query 'restore <local:///topazproject> from <file:/home/topazdev/backup/serverbackup.gz>;':
org.mulgara.query.QueryException: java.lang.InterruptedException: null
tql> 

#1

Updated by Dragisa Krsmanovic - over 14 years ago

After this failure it's impossible to restart Mulgara.

Error on startup:

2009-12-03 15:14:49,389 ERROR XAStringPoolImpl> I/O error while performing prepare. [main org.mulgara.store.stringpool.xa.XAStringPoolImpl]
java.io.IOException: No space left on device
    at java.nio.MappedByteBuffer.force0(Native Method)
    at java.nio.MappedByteBuffer.force(MappedByteBuffer.java:154)
    at org.mulgara.util.MappedIntFile.force(MappedIntFile.java:291)
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl.prepare(XAStringPoolImpl.java:642)
    at org.mulgara.resolver.StringPoolSession.prepare(StringPoolSession.java:277)
    at org.mulgara.resolver.store.StatementStoreXAResource.doPrepare(StatementStoreXAResource.java:129)
    at org.mulgara.resolver.store.StatementStoreXAResource.doPrepare(StatementStoreXAResource.java:60)
    at org.mulgara.resolver.spi.AbstractXAResource.commit(AbstractXAResource.java:188)
    at org.objectweb.jotm.SubCoordinator.doOnePhaseCommit(SubCoordinator.java:1255)
    at org.objectweb.jotm.SubCoordinator.commit_one_phase(SubCoordinator.java:451)
    at org.objectweb.jotm.TransactionImpl.commit(TransactionImpl.java:239)
    at org.mulgara.resolver.MulgaraInternalTransaction.commitTransaction(MulgaraInternalTransaction.java:365)
    at org.mulgara.resolver.MulgaraInternalTransaction.deactivate(MulgaraInternalTransaction.java:194)
    at org.mulgara.resolver.MulgaraInternalTransaction.execute(MulgaraInternalTransaction.java:631)
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:751)
    at org.mulgara.resolver.DatabaseSession.bootstrapSystemModel(DatabaseSession.java:309)
    at org.mulgara.resolver.Database.<init>(Database.java:988)
    at org.mulgara.resolver.Database.<init>(Database.java:536)
    at org.mulgara.resolver.Database.<init>(Database.java:321)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
    at org.mulgara.server.AbstractServer.init(AbstractServer.java:276)
    at org.mulgara.server.EmbeddedMulgaraServer.startServices(EmbeddedMulgaraServer.java:410)
    at org.mulgara.server.EmbeddedMulgaraServer.main(EmbeddedMulgaraServer.java:185)
2009-12-03 15:14:49,390 ERROR XAStringPoolImpl> Prepare failed. [main org.mulgara.store.stringpool.xa.XAStringPoolImpl]
2009-12-03 15:14:49,391 ERROR [[AbstractXAResource]]> Attempt to prepare in onePhaseCommit failed. [main org.mulgara.resolver.spi.AbstractXAResource]
org.mulgara.store.xa.SimpleXAResourceException: I/O error while performing prepare.
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl.prepare(XAStringPoolImpl.java:664)
    at org.mulgara.resolver.StringPoolSession.prepare(StringPoolSession.java:277)
    at org.mulgara.resolver.store.StatementStoreXAResource.doPrepare(StatementStoreXAResource.java:129)
    at org.mulgara.resolver.store.StatementStoreXAResource.doPrepare(StatementStoreXAResource.java:60)
    at org.mulgara.resolver.spi.AbstractXAResource.commit(AbstractXAResource.java:188)
    at org.objectweb.jotm.SubCoordinator.doOnePhaseCommit(SubCoordinator.java:1255)
    at org.objectweb.jotm.SubCoordinator.commit_one_phase(SubCoordinator.java:451)
    at org.objectweb.jotm.TransactionImpl.commit(TransactionImpl.java:239)
    at org.mulgara.resolver.MulgaraInternalTransaction.commitTransaction(MulgaraInternalTransaction.java:365)
    at org.mulgara.resolver.MulgaraInternalTransaction.deactivate(MulgaraInternalTransaction.java:194)
    at org.mulgara.resolver.MulgaraInternalTransaction.execute(MulgaraInternalTransaction.java:631)
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:751)
    at org.mulgara.resolver.DatabaseSession.bootstrapSystemModel(DatabaseSession.java:309)
    at org.mulgara.resolver.Database.<init>(Database.java:988)
    at org.mulgara.resolver.Database.<init>(Database.java:536)
    at org.mulgara.resolver.Database.<init>(Database.java:321)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
    at org.mulgara.server.AbstractServer.init(AbstractServer.java:276)
    at org.mulgara.server.EmbeddedMulgaraServer.startServices(EmbeddedMulgaraServer.java:410)
    at org.mulgara.server.EmbeddedMulgaraServer.main(EmbeddedMulgaraServer.java:185)
Caused by: java.io.IOException: No space left on device
    at java.nio.MappedByteBuffer.force0(Native Method)
    at java.nio.MappedByteBuffer.force(MappedByteBuffer.java:154)
    at org.mulgara.util.MappedIntFile.force(MappedIntFile.java:291)
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl.prepare(XAStringPoolImpl.java:642)
    ... 22 more
2009-12-03 15:14:49,431 ERROR jotm> Got XAException from res.commit: Cannot send res.commit:javax.transaction.xa.XAException (error code = 100) --null [main org.objectweb.jotm]
2009-12-03 15:14:49,433 ERROR jotm> rollback: bad status: STATUS_UNKNOWN [main org.objectweb.jotm]
2009-12-03 15:14:49,435 ERROR [[EmbeddedMulgaraServer]]> Exception in main [main org.mulgara.server.EmbeddedMulgaraServer]
java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
    at org.mulgara.server.AbstractServer.init(AbstractServer.java:276)
    at org.mulgara.server.EmbeddedMulgaraServer.startServices(EmbeddedMulgaraServer.java:410)
    at org.mulgara.server.EmbeddedMulgaraServer.main(EmbeddedMulgaraServer.java:185)
Caused by: org.mulgara.query.QueryException: Failed to bootstrap system-model: org.mulgara.query.MulgaraTransactionException
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:754)
    at org.mulgara.resolver.DatabaseSession.bootstrapSystemModel(DatabaseSession.java:309)
    at org.mulgara.resolver.Database.<init>(Database.java:988)
    at org.mulgara.resolver.Database.<init>(Database.java:536)
    at org.mulgara.resolver.Database.<init>(Database.java:321)
    ... 7 more
Caused by: org.mulgara.query.MulgaraTransactionException: Transaction rollback triggered
    at org.mulgara.resolver.MulgaraInternalTransaction.implicitRollback(MulgaraInternalTransaction.java:516)
    at org.mulgara.resolver.MulgaraInternalTransaction.commitTransaction(MulgaraInternalTransaction.java:367)
    at org.mulgara.resolver.MulgaraInternalTransaction.deactivate(MulgaraInternalTransaction.java:194)
    at org.mulgara.resolver.MulgaraInternalTransaction.execute(MulgaraInternalTransaction.java:631)
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:751)
    ... 11 more
Caused by: javax.transaction.RollbackException
    at org.objectweb.jotm.TransactionImpl.commit(TransactionImpl.java:245)
    at org.mulgara.resolver.MulgaraInternalTransaction.commitTransaction(MulgaraInternalTransaction.java:365)
    ... 14 more

It complains of "No space left on device". It looks like there are 4G left :

df -v
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda1             10321208   5662468   4134452  58% /
/dev/sdb             433455904    203016 411234584   1% /mnt
#2

Updated by Dragisa Krsmanovic - over 14 years ago

Mulgara version is 2.1.4 not 2.0.14. Sorry. (Trac 0.11 lets you edit the ticket)

#3

Updated by Paula Gearon over 14 years ago

For the original error:

You've provided the log of the client end, but there is no indication of what happened with the server. All I know is that the server sent some kind of exception (bad data maybe?!?) but the client somehow wasn't configured to accept this exception. As for not accepting the exception, I'm confused here as it isn't the kind of RMI exception I usually see. As for what happened on the server, you'll need to provide the server's log file.

#4

Updated by Paula Gearon over 14 years ago

For the followup error:

Are you running the same version of Mulgara as you were running earlier? This bug report says that you are using an XA string pool, but I thought you'd moved to XA 1.1? If the files were originally created with XA 1.1, then attempting to load them with XA could cause this, since XA 1.1 stores extra bits in file indexes, and if these bits are not stripped out then a file seek will be sent off to an offset that is too large for any hard drive (offsets starting at 2^62).

Can you please confirm if you've changed from XA 1.1 to XA 1?

#5

Updated by Dragisa Krsmanovic - over 14 years ago

It's XA 1.0

I suspect it was lack of space that caused restore error. But restore failure should not corrupt whole database.

#6

Updated by Paula Gearon over 14 years ago

  • Status changed from New to Closed
  • Resolution set to invalid

Also available in: Atom PDF