Project

General

Profile

Bug #2

"Multiple writers not supported" transactioning error occurs if reading and writing concurrently

Added by stephen.bayliss - about 16 years ago. Updated over 15 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Category:
Mulgara
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed

Description

Errors while attempting to read and write to the same model, from different iTQL sessions.
<br/>

<br/>
- Repeatedly load a file containing (eg) 5000 statements in one iTQL session, for example through an iTQL script
<br/>
- concurrently, repeatedly issue queries from another iTQL session, eg used select $s $p $o from &lt;<a href="rmi://localhost/server1#tranTest">rmi://localhost/server1#tranTest</a>&gt; where $s $p $o limit 100;
<br/>

<br/>
Periodically the following error occurs:
<br/>

<br/>
2006-06-22 13:15:24,839 ERROR [[StatementStoreXAResource]] - Attempting to prepare from different transaction. Multiple writers not supported
<br/>

<br/>
2006-06-22 13:15:24,839 ERROR [[SubCoordinator]] - Got XAException from
<br/>
resource.prepare: Cannot send
<br/>
res.prepare:javax.transaction.xa.XAException (error code = -4) -null
<br/>

#1

Updated by stephen.bayliss - almost 16 years ago

Replicated this on the released version, Mulgara 1.0 (Sun Java 1.5.0_08, Intel).
#2

Updated by Paula Gearon almost 16 years ago

This problem is the result of a fix to an ACID problem.  Currently the only way to avoid the error is to prevent a new transaction from being established.  The ACID problem is described in <a href="http://mulgara.org/trac/ticket/19">http://mulgara.org/trac/ticket/19</a>
#3

Updated by Paula Gearon almost 16 years ago

Perform as part of <a href="http://mulgara.org/trac/ticket/19">http://mulgara.org/trac/ticket/19</a>
#4

Updated by Andrae Muys - almost 16 years ago

I've taken a closer look at this, and it may be a seperate issue to <a href="http://mulgara.org/trac/ticket/19" title="Fix transaction support in Mulgara to support concurrent reads and read-only transactions. - Currently ACID failure"><strike>MGR-19</strike></a>.  It appears to be related to concurrent calls to prepare() on [[StatementStoreXAResource]].
#5

Updated by stephen.bayliss - almost 16 years ago

Tested this again in revision <a href="http://mulgara.org/trac/changeset/106">106</a>.  Looks like the problem is fixed, I can no longer reproduce.  Good news!
<br/>

<br/>
(Java 1.5.0_09, AMD, Windows XP SP2)
#6

Updated by Andrae Muys - almost 16 years ago

Should be fixed in r106.
<br/>

<br/>
Please test and confirm.
#7

Updated by Andrae Muys - over 15 years ago

Fix Confirmed

Also available in: Atom PDF