Project

General

Profile

Bug #179

Doing a FILTER REGEX with 2 parameters gives an error

Added by Paula Gearon over 13 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Mulgara
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed

Description

Simple queries with 2 parameter regex filters fail with NPE. e.g.:

select * where { ?s ?p ?o filter regex(?o, ".*sold.*") }


  
#1

Updated by Paula Gearon over 13 years ago

The error message being printed was the message of the "Cause", but NPEs have neither a cause nor a message. So the name of the exception is being printed. See r1474.

The NPE was being caused by the regex class expecting a "flags" parameter, though this is optional. Cleaned up code in several places to handle nulls in this argument. Fixed in r1473.

#2

Updated by Paula Gearon over 13 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Also available in: Atom PDF