Project

General

Profile

Feature #160

Cache lucene indexes

Added by ronald - about 14 years ago. Updated about 14 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Mulgara
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
duplicate

Description

The lucene indexes in the [source:trunk/src/jar/resolver-lucene/ lucene resolver]
are created anew for each transaction; this is fairly costly. We should cached them
across transactions, re-opening them if a modification occurred since the last time
they were checked out.

#1

Updated by ronald - about 14 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

This is a duplicate of #158.

Also available in: Atom PDF