Project

General

Profile

Bug #12

Cannot backup mulgara while performing querying, inserting, or deleting

Added by ben hysell - over 16 years ago. Updated over 15 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Mulgara
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed

Description

While running mulgara and performing inserting, deleting, ect I attempt to run a backup from the webui.  Webui returns:
<br/>

<br/>
Results:     (1 query, 632.672 seconds)
<br/>
Query Executed:
<br/>
    backup &lt;<a href="rmi://192.168.100.103/server1">rmi://192.168.100.103/server1</a>&gt; to &lt;file:/c:/test.txt.gz&gt;;
<br/>
Result Message:     org.mulgara.query.QueryException: Unable to backup to file:/c:/test.txt.gz
<br/>

<br/>
Mulgara command window:
<br/>
2006-08-21 13:46:05,132 ERROR [RMI TCP Connection(29)-192.168.100.103] store.StatementStoreXAResource - Attempting to prepare from different transaction. Multiple writers not supported
<br/>
2006-08-21 13:46:05,147 ERROR [RMI TCP Connection(29)-192.168.100.103] store.StatementStoreXAResource - Attempt to prepare in onePhaseCommit failed.
<br/>
javax.transaction.xa.XAException
<br/>
    at org.mulgara.resolver.store.StatementStoreXAResource.prepare(StatementStoreXAResource.java:169)
<br/>
    at org.mulgara.resolver.store.StatementStoreXAResource.commit(StatementStoreXAResource.java:202)
<br/>
    at org.objectweb.jotm.SubCoordinator.doOnePhaseCommit(SubCoordinator.java:893)
<br/>
    at org.objectweb.jotm.SubCoordinator.commit_one_phase(SubCoordinator.java:397)
<br/>
    at org.objectweb.jotm.TransactionImpl.commit(TransactionImpl.java:222)
<br/>
    at org.objectweb.jotm.Current.commit(Current.java:442)
<br/>
    at org.mulgara.resolver.DatabaseSession.endTransactionalBlock(DatabaseSession.java:1496)
<br/>
    at org.mulgara.resolver.DatabaseSession.finishTransactionalOperation(DatabaseSession.java:1775)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1396)
<br/>
    at org.mulgara.resolver.DatabaseSession.backup(DatabaseSession.java:547)
<br/>
    at org.mulgara.resolver.DatabaseSession.backup(DatabaseSession.java:517)
<br/>
    at org.mulgara.server.rmi.SessionWrapperRemoteSession.backup(SessionWrapperRemoteSession.java:222)
<br/>
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
<br/>
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
<br/>
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
<br/>
    at java.security.AccessController.doPrivileged(Native Method)
<br/>
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
<br/>
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
<br/>
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
<br/>
    at java.lang.Thread.run(Thread.java:595)
<br/>
2006-08-21 13:46:05,147 ERROR [RMI TCP Connection(29)-192.168.100.103] jotm.SubCoordinator - Got XAException from resource.commit: Cannot send res.commit:javax.transaction.xa.XAException (error code = 100) --null
<br/>
2006-08-21 13:46:05,163 WARN  [PoolThread-1] itql.ItqlInterpreter - Failed to backup server <a href="rmi://192.168.100.103/server1">rmi://192.168.100.103/server1</a> to file:/c:/test.txt.gz
<br/>
org.mulgara.query.QueryException: Unable to backup to file:/c:/test.txt.gz
<br/>
    at org.mulgara.resolver.DatabaseSession.endTransactionalBlock(DatabaseSession.java:1512)
<br/>
    at org.mulgara.resolver.DatabaseSession.finishTransactionalOperation(DatabaseSession.java:1775)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1396)
<br/>
    at org.mulgara.resolver.DatabaseSession.backup(DatabaseSession.java:547)
<br/>
    at org.mulgara.resolver.DatabaseSession.backup(DatabaseSession.java:517)
<br/>
    at org.mulgara.server.rmi.SessionWrapperRemoteSession.backup(SessionWrapperRemoteSession.java:222)
<br/>
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
<br/>
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
<br/>
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
<br/>
    at java.security.AccessController.doPrivileged(Native Method)
<br/>
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
<br/>
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
<br/>
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
<br/>
    at java.lang.Thread.run(Thread.java:595)
<br/>
    at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
<br/>
    at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
<br/>
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:126)
<br/>
    at org.mulgara.server.rmi.RemoteSessionImpl_Stub.backup(Unknown Source)
<br/>
    at org.mulgara.server.rmi.RemoteSessionWrapperSession.backup(RemoteSessionWrapperSession.java:299)
<br/>
    at org.mulgara.itql.ItqlInterpreter.outABackupCommand(ItqlInterpreter.java:2381)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseABackupCommand(DepthFirstAdapter.java:157)
<br/>
    at org.mulgara.itql.node.ABackupCommand.apply(ABackupCommand.java:50)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseACommandStart(DepthFirstAdapter.java:51)
<br/>
    at org.mulgara.itql.node.ACommandStart.apply(ACommandStart.java:30)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseStart(DepthFirstAdapter.java:31)
<br/>
    at org.mulgara.itql.node.Start.apply(Start.java:33)
<br/>
    at org.mulgara.itql.ItqlInterpreter.executeCommand(ItqlInterpreter.java:508)
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.executeQueryToNiceResult(ItqlInterpreterBean.java:1004)
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.executeQueryToList(ItqlInterpreterBean.java:532)
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.executeQueryToList(ItqlInterpreterBean.java:481)
<br/>
    at org.mulgara.webui.viewer.ViewerScreen$ExecuteQueryHandler.executeQuery(ViewerScreen.java:621)
<br/>
    at org.mulgara.webui.viewer.ViewerScreen$ExecuteQueryHandler.handleControlEvent(ViewerScreen.java:491)
<br/>
    at org.enhydra.barracuda.core.event.DefaultBaseEventListener.handleEvent(DefaultBaseEventListener.java:61)
<br/>
    at org.enhydra.barracuda.core.event.DefaultEventDispatcher.notifyListeners(DefaultEventDispatcher.java:421)
<br/>
    at org.enhydra.barracuda.core.event.DefaultEventDispatcher.dispatch(DefaultEventDispatcher.java:185)
<br/>
    at org.enhydra.barracuda.core.event.DefaultEventDispatcher.dispatchEvent(DefaultEventDispatcher.java:105)
<br/>
    at org.enhydra.barracuda.core.event.DefaultEventBroker.dispatchEvent(DefaultEventBroker.java:447)
<br/>
    at org.enhydra.barracuda.core.event.ApplicationGateway.handleDefaultExt(ApplicationGateway.java:693)
<br/>
    at org.enhydra.barracuda.core.event.ApplicationGateway.handleDefault(ApplicationGateway.java:257)
<br/>
    at org.enhydra.barracuda.core.event.ApplicationGateway.doPost(ApplicationGateway.java:1138)
<br/>
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
<br/>
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
<br/>
    at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:354)
<br/>
    at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:294)
<br/>
    at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:567)
<br/>
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1808)
<br/>
    at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:525)
<br/>
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1758)
<br/>
    at org.mortbay.http.HttpServer.service(HttpServer.java:879)
<br/>
    at org.mortbay.http.HttpConnection.service(HttpConnection.java:790)
<br/>
    at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:952)
<br/>
    at org.mortbay.http.HttpConnection.handle(HttpConnection.java:807)
<br/>
    at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:197)
<br/>
    at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:289)
<br/>
    at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:501)
<br/>
Caused by: org.mulgara.query.QueryException: javax.transaction.RollbackException: null
<br/>
    at org.objectweb.jotm.TransactionImpl.commit(TransactionImpl.java:225)
<br/>
    at org.objectweb.jotm.Current.commit(Current.java:442)
<br/>
    at org.mulgara.resolver.DatabaseSession.endTransactionalBlock(DatabaseSession.java:1496)
<br/>
    at org.mulgara.resolver.DatabaseSession.finishTransactionalOperation(DatabaseSession.java:1775)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1396)
<br/>
    at org.mulgara.resolver.DatabaseSession.backup(DatabaseSession.java:547)
<br/>
    at org.mulgara.resolver.DatabaseSession.backup(DatabaseSession.java:517)
<br/>
    at org.mulgara.server.rmi.SessionWrapperRemoteSession.backup(SessionWrapperRemoteSession.java:222)
<br/>
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
<br/>
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
<br/>
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
<br/>
    at java.security.AccessController.doPrivileged(Native Method)
<br/>
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
<br/>
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
<br/>
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
<br/>
    at java.lang.Thread.run(Thread.java:595)
<br/>

<br/>
The actual backup file I was producing, its size is very close to the size I would expect, indicating to me it almost finished.  
<br/>
I've also had this issue on a redhat linux machine, same issue, same computer setup.
#1

Updated by Paula Gearon over 16 years ago

Do you get the same behaviour with the iTQL shell?
#2

Updated by ben hysell - over 16 years ago

This is the output from the itql shell...this also killed one of my batch processes and failed to backup.
<br/>

<br/>

<br/>
2006-08-21 15:28:19,882 WARN  [PoolThread-3] itql.ItqlInterpreter - Failed to insert statements into <a href="rmi://192.168.100.103/server1#data">rmi://192.168.100.103/server1#data</a>
<br/>
org.mulgara.query.QueryException: Could not commit insert
<br/>
    at org.mulgara.resolver.DatabaseSession.endTransactionalBlock(DatabaseSession.java:1512)
<br/>
    at org.mulgara.resolver.DatabaseSession.finishTransactionalOperation(DatabaseSession.java:1775)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1396)
<br/>
    at org.mulgara.resolver.DatabaseSession.modify(DatabaseSession.java:625)
<br/>
    at org.mulgara.resolver.DatabaseSession.insert(DatabaseSession.java:608)
<br/>
    at org.mulgara.server.rmi.SessionWrapperRemoteSession.insert(SessionWrapperRemoteSession.java:170)
<br/>
    at sun.reflect.GeneratedMethodAccessor25.invoke(Unknown Source)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
<br/>
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
<br/>
    at java.security.AccessController.doPrivileged(Native Method)
<br/>
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
<br/>
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
<br/>
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
<br/>
    at java.lang.Thread.run(Thread.java:595)
<br/>
    at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
<br/>
    at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
<br/>
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:126)
<br/>
    at org.mulgara.server.rmi.RemoteSessionImpl_Stub.insert(Unknown Source)
<br/>
    at org.mulgara.server.rmi.RemoteSessionWrapperSession.insert(RemoteSessionWrapperSession.java:235)
<br/>
    at org.mulgara.itql.ItqlInterpreter.insertStatements(ItqlInterpreter.java:2801)
<br/>
    at org.mulgara.itql.ItqlInterpreter.outAInsertCommand(ItqlInterpreter.java:2066)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseAInsertCommand(DepthFirstAdapter.java:365)
<br/>
    at org.mulgara.itql.node.AInsertCommand.apply(AInsertCommand.java:45)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseACommandStart(DepthFirstAdapter.java:51)
<br/>
    at org.mulgara.itql.node.ACommandStart.apply(ACommandStart.java:30)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseStart(DepthFirstAdapter.java:31)
<br/>
    at org.mulgara.itql.node.Start.apply(Start.java:33)
<br/>
    at org.mulgara.itql.ItqlInterpreter.executeCommand(ItqlInterpreter.java:508)
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.execute(ItqlInterpreterBean.java:391)
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.executeQueryToString(ItqlInterpreterBean.java:446)
<br/>
    at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:402)
<br/>
    at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:309)
<br/>
    at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:333)
<br/>
    at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:71)
<br/>
    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:150)
<br/>
    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:120)
<br/>
    at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:481)
<br/>
    at org.apache.axis.server.AxisServer.invoke(AxisServer.java:323)
<br/>
    at org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:854)
<br/>
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
<br/>
    at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:339)
<br/>
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
<br/>
    at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:354)
<br/>
    at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:294)
<br/>
    at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:567)
<br/>
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1808)
<br/>
    at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:525)
<br/>
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1758)
<br/>
    at org.mortbay.http.HttpServer.service(HttpServer.java:879)
<br/>
    at org.mortbay.http.HttpConnection.service(HttpConnection.java:790)
<br/>
    at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:952)
<br/>
    at org.mortbay.http.HttpConnection.handle(HttpConnection.java:807)
<br/>
    at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:197)
<br/>
    at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:289)
<br/>
    at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:501)
<br/>
Caused by: org.mulgara.query.QueryException: javax.transaction.RollbackException: null
<br/>
    at org.objectweb.jotm.TransactionImpl.commit(TransactionImpl.java:225)
<br/>
    at org.objectweb.jotm.Current.commit(Current.java:442)
<br/>
    at org.mulgara.resolver.DatabaseSession.endTransactionalBlock(DatabaseSession.java:1499)
<br/>
    at org.mulgara.resolver.DatabaseSession.finishTransactionalOperation(DatabaseSession.java:1775)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1396)
<br/>
    at org.mulgara.resolver.DatabaseSession.modify(DatabaseSession.java:625)
<br/>
    at org.mulgara.resolver.DatabaseSession.insert(DatabaseSession.java:608)
<br/>
    at org.mulgara.server.rmi.SessionWrapperRemoteSession.insert(SessionWrapperRemoteSession.java:170)
<br/>
    at sun.reflect.GeneratedMethodAccessor25.invoke(Unknown Source)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
<br/>
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
<br/>
    at java.security.AccessController.doPrivileged(Native Method)
<br/>
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
<br/>
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
<br/>
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
<br/>
    at java.lang.Thread.run(Thread.java:595)
<br/>
Caused by: java.lang.IllegalStateException: Attempt to modify a node for a read-only phase.
<br/>
    at org.mulgara.store.xa.AVLNode.modify(AVLNode.java:745)
<br/>
    at org.mulgara.store.xa.AVLNode.insert(AVLNode.java:851)
<br/>
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl$Phase.put(XAStringPoolImpl.java:1472)
<br/>
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl$Phase.put(XAStringPoolImpl.java:1422)
<br/>
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl.put(XAStringPoolImpl.java:337)
<br/>
    at org.mulgara.resolver.StringPoolSession.localizeSPObject(StringPoolSession.java:546)
<br/>
    at org.mulgara.resolver.StringPoolSession.localize(StringPoolSession.java:416)
<br/>
    at org.mulgara.resolver.StringPoolSession.localizePersistent(StringPoolSession.java:217)
<br/>
    at org.mulgara.resolver.store.StatementStoreResolver.localizePersistent(StatementStoreResolver.java:451)
<br/>
    at org.mulgara.resolver.spi.TripleSetWrapperStatements.localize(TripleSetWrapperStatements.java:180)
<br/>
    at org.mulgara.resolver.spi.TripleSetWrapperStatements.getSubject(TripleSetWrapperStatements.java:160)
<br/>
    at org.mulgara.resolver.store.StatementStoreResolver.modifyModel(StatementStoreResolver.java:352)
<br/>
    at org.mulgara.resolver.InternalResolver.modifyModel(InternalResolver.java:161)
<br/>
    at org.mulgara.resolver.ModifyModelOperation.doModify(ModifyModelOperation.java:252)
<br/>
    at org.mulgara.resolver.ModifyModelOperation.execute(ModifyModelOperation.java:212)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1392)
<br/>
    ... 13 more
<br/>
2006-08-21 15:28:19,913 ERROR [PoolThread-3] itql.ItqlInterpreterBean - Execute query failed.  Returning error
<br/>
org.mulgara.itql.ItqlInterpreterException: org.mulgara.query.QueryException: Could not commit insert
<br/>
    at org.mulgara.itql.ItqlInterpreter.setLastError(ItqlInterpreter.java:2535)
<br/>
    at org.mulgara.itql.ItqlInterpreter.outAInsertCommand(ItqlInterpreter.java:2083)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseAInsertCommand(DepthFirstAdapter.java:365)
<br/>
    at org.mulgara.itql.node.AInsertCommand.apply(AInsertCommand.java:45)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseACommandStart(DepthFirstAdapter.java:51)
<br/>
    at org.mulgara.itql.node.ACommandStart.apply(ACommandStart.java:30)
<br/>
    at org.mulgara.itql.analysis.DepthFirstAdapter.caseStart(DepthFirstAdapter.java:31)
<br/>
    at org.mulgara.itql.node.Start.apply(Start.java:33)
<br/>
    at org.mulgara.itql.ItqlInterpreter.executeCommand(ItqlInterpreter.java:508)
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.execute(ItqlInterpreterBean.java:391)
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.executeQueryToString(ItqlInterpreterBean.java:446)
<br/>
    at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:402)
<br/>
    at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:309)
<br/>
    at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:333)
<br/>
    at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:71)
<br/>
    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:150)
<br/>
    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:120)
<br/>
    at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:481)
<br/>
    at org.apache.axis.server.AxisServer.invoke(AxisServer.java:323)
<br/>
    at org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:854)
<br/>
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
<br/>
    at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:339)
<br/>
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
<br/>
    at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:354)
<br/>
    at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:294)
<br/>
    at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:567)
<br/>
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1808)
<br/>
    at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:525)
<br/>
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1758)
<br/>
    at org.mortbay.http.HttpServer.service(HttpServer.java:879)
<br/>
    at org.mortbay.http.HttpConnection.service(HttpConnection.java:790)
<br/>
    at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:952)
<br/>
    at org.mortbay.http.HttpConnection.handle(HttpConnection.java:807)
<br/>
    at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:197)
<br/>
    at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:289)
<br/>
    at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:501)
<br/>
Caused by: org.mulgara.query.QueryException: Could not commit insert
<br/>
    at org.mulgara.resolver.DatabaseSession.endTransactionalBlock(DatabaseSession.java:1512)
<br/>
    at org.mulgara.resolver.DatabaseSession.finishTransactionalOperation(DatabaseSession.java:1775)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1396)
<br/>
    at org.mulgara.resolver.DatabaseSession.modify(DatabaseSession.java:625)
<br/>
    at org.mulgara.resolver.DatabaseSession.insert(DatabaseSession.java:608)
<br/>
    at org.mulgara.server.rmi.SessionWrapperRemoteSession.insert(SessionWrapperRemoteSession.java:170)
<br/>
    at sun.reflect.GeneratedMethodAccessor25.invoke(Unknown Source)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
<br/>
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
<br/>
    at java.security.AccessController.doPrivileged(Native Method)
<br/>
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
<br/>
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
<br/>
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
<br/>
    at java.lang.Thread.run(Thread.java:595)
<br/>
    at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
<br/>
    at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
<br/>
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:126)
<br/>
    at org.mulgara.server.rmi.RemoteSessionImpl_Stub.insert(Unknown Source)
<br/>
    at org.mulgara.server.rmi.RemoteSessionWrapperSession.insert(RemoteSessionWrapperSession.java:235)
<br/>
    at org.mulgara.itql.ItqlInterpreter.insertStatements(ItqlInterpreter.java:2801)
<br/>
    at org.mulgara.itql.ItqlInterpreter.outAInsertCommand(ItqlInterpreter.java:2066)
<br/>
    ... 37 more
<br/>
Caused by: org.mulgara.query.QueryException: javax.transaction.RollbackException: null
<br/>
    at org.objectweb.jotm.TransactionImpl.commit(TransactionImpl.java:225)
<br/>
    at org.objectweb.jotm.Current.commit(Current.java:442)
<br/>
    at org.mulgara.resolver.DatabaseSession.endTransactionalBlock(DatabaseSession.java:1499)
<br/>
    at org.mulgara.resolver.DatabaseSession.finishTransactionalOperation(DatabaseSession.java:1775)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1396)
<br/>
    at org.mulgara.resolver.DatabaseSession.modify(DatabaseSession.java:625)
<br/>
    at org.mulgara.resolver.DatabaseSession.insert(DatabaseSession.java:608)
<br/>
    at org.mulgara.server.rmi.SessionWrapperRemoteSession.insert(SessionWrapperRemoteSession.java:170)
<br/>
    at sun.reflect.GeneratedMethodAccessor25.invoke(Unknown Source)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
<br/>
    at sun.rmi.transport.Transport$1.run(Transport.java:153)
<br/>
    at java.security.AccessController.doPrivileged(Native Method)
<br/>
    at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
<br/>
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
<br/>
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
<br/>
    at java.lang.Thread.run(Thread.java:595)
<br/>
Caused by: java.lang.IllegalStateException: Attempt to modify a node for a read-only phase.
<br/>
    at org.mulgara.store.xa.AVLNode.modify(AVLNode.java:745)
<br/>
    at org.mulgara.store.xa.AVLNode.insert(AVLNode.java:851)
<br/>
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl$Phase.put(XAStringPoolImpl.java:1472)
<br/>
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl$Phase.put(XAStringPoolImpl.java:1422)
<br/>
    at org.mulgara.store.stringpool.xa.XAStringPoolImpl.put(XAStringPoolImpl.java:337)
<br/>
    at org.mulgara.resolver.StringPoolSession.localizeSPObject(StringPoolSession.java:546)
<br/>
    at org.mulgara.resolver.StringPoolSession.localize(StringPoolSession.java:416)
<br/>
    at org.mulgara.resolver.StringPoolSession.localizePersistent(StringPoolSession.java:217)
<br/>
    at org.mulgara.resolver.store.StatementStoreResolver.localizePersistent(StatementStoreResolver.java:451)
<br/>
    at org.mulgara.resolver.spi.TripleSetWrapperStatements.localize(TripleSetWrapperStatements.java:180)
<br/>
    at org.mulgara.resolver.spi.TripleSetWrapperStatements.getSubject(TripleSetWrapperStatements.java:160)
<br/>
    at org.mulgara.resolver.store.StatementStoreResolver.modifyModel(StatementStoreResolver.java:352)
<br/>
    at org.mulgara.resolver.InternalResolver.modifyModel(InternalResolver.java:161)
<br/>
    at org.mulgara.resolver.ModifyModelOperation.doModify(ModifyModelOperation.java:252)
<br/>
    at org.mulgara.resolver.ModifyModelOperation.execute(ModifyModelOperation.java:212)
<br/>
    at org.mulgara.resolver.DatabaseSession.execute(DatabaseSession.java:1392)
<br/>
    ... 13 more
<br/>
2006-08-21 15:28:19,944 ERROR [PoolThread-3] itql.ItqlInterpreterBean - Failed to execute query
<br/>
javax.xml.soap.SOAPException: [[ItqlInterpreter]] error - org.mulgara.query.QueryException: Could not commit insert
<br/>
Caused by: (QueryException) Could not commit insert
<br/>
Caused by: (QueryException) javax.transaction.RollbackException: null
<br/>
Caused by: (IllegalStateException) Attempt to modify a node for a read-only phase.
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.execute(ItqlInterpreterBean.java:412)
<br/>
    at org.mulgara.itql.ItqlInterpreterBean.executeQueryToString(ItqlInterpreterBean.java:446)
<br/>
    at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
<br/>
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
<br/>
    at java.lang.reflect.Method.invoke(Method.java:585)
<br/>
    at org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:402)
<br/>
    at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:309)
<br/>
    at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:333)
<br/>
    at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:71)
<br/>
    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:150)
<br/>
    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:120)
<br/>
    at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:481)
<br/>
    at org.apache.axis.server.AxisServer.invoke(AxisServer.java:323)
<br/>
    at org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:854)
<br/>
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
<br/>
    at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:339)
<br/>
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
<br/>
    at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:354)
<br/>
    at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:294)
<br/>
    at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:567)
<br/>
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1808)
<br/>
    at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:525)
<br/>
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1758)
<br/>
    at org.mortbay.http.HttpServer.service(HttpServer.java:879)
<br/>
    at org.mortbay.http.HttpConnection.service(HttpConnection.java:790)
<br/>
    at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:952)
<br/>
    at org.mortbay.http.HttpConnection.handle(HttpConnection.java:807)
<br/>
    at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:197)
<br/>
    at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:289)
<br/>
    at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:501)
#3

Updated by Paula Gearon over 16 years ago

This looks like backup is attempting to capture the writing thread.  I don't believe that this is necessary, as it should be read-only operation.  This is the first place to investigate.
#4

Updated by stephen.bayliss - over 16 years ago

The exception looks similar to what I was getting in <a href="http://mulgara.org/trac/ticket/2">http://mulgara.org/trac/ticket/2</a> -- could be related?  I had problems reading from one session when writing was happening in another.  This was on Kowari 1.2, I'm about to check this out for Mulgara 1.0.0.
#5

Updated by Andrae Muys - almost 16 years ago

With the extensive changes to the transaction management the above stacktraces are definately no longer relevant.
<br/>

<br/>
Could you please try and reproduce with the current svn-HEAD and let us know if the problem still exists?
#6

Updated by Paula Gearon almost 16 years ago

The transaction changes have now been integrated into &quot;trunk&quot;.  We've also cleaned it up a little for robustness.
<br/>

<br/>
Please give it a go, and let us know how it works for you.
#7

Updated by Andrae Muys - over 15 years ago

No further reports on this issue since the transaction fixes.
<br/>

<br/>
Will give it a month and close this issue if there are no reports of a recurrence.
<br/>

Also available in: Atom PDF